Volkswagen ID Forum banner
21 - 31 of 31 Posts

·
Registered User
Joined
·
733 Posts
Can’t wait! The slowness in the UI is really the only issue we’ve had with the car in the first 500 miles or so… and it’s not horrible, just a minor irritant. (Only other issue is the rear light bar that expands in the sun, but I’m sure there’ll be a TSB on that.)
except for the boot time (which still is less in 2.3, but far from instant), no interface lag for me. And I have all the bells and whistles enabled.
 

·
Registered User
Joined
·
183 Posts
The boot time is what I’m referring to - it’s annoying that you go for a drive and having to wait until your a few blocks from home to change anything :)
 

·
Registered User
Joined
·
798 Posts
Had that error once, never re-appeared. I chalk it up to just another ID4 glitch or "blue screen".
Maybe a certain sequence of non-errors triggers a false error that clears after the "30 min waiting period".
Maybe we're running a virtual operating system(OS) inside the ID4 OS that needs time to reboot the virtual machine.
I wonder what the ID4 OS is based on 🤔?
 

·
Registered User
Joined
·
776 Posts
wonder what the ID4 OS is based on
Some of the subsystems run their own embedded QNX or others, but the main ICAS (in-car app server) is Linux with Java on top, similar to android. We don't know how much of that is from the AAOS (android open source project) yet. Much more here:
 
  • Like
  • Wow
Reactions: Huey52 and BlueDH

·
Registered User
Joined
·
798 Posts
Some of the subsystems run their own embedded QNX or others, but the main ICAS (in-car app server) is Linux with Java on top, similar to android. We don't know how much of that is from the AAOS (android open source project) yet. Much more here:
Thanks for the link.
 

·
Registered User
Joined
·
34 Posts
It is a computer after all - Control-Alt-Delete and you're good to go!

Don
Except that sometimes the error messages stop, the car won't go into any gear, and rebooting ceases to work. My 4 month long experience with this error was only solved recently by replacing the part related to the gear selector switch which I have posted about previously. Since replacing this part I had 4 weeks of error free driving, until yesterday. A red error message popped up "Electrical system not functioning properly, service the vehicle." As before, rebooting "fixed" the error. Stay tuned.
 

·
Registered User
Joined
·
136 Posts
Discussion Starter · #28 ·
So, I wanted to give everyone an update. I ended up canceling my appointment and I figured I would just have them see if there was an error code at the 30 day check up (you can go to any dealer for that, right? )

My car has been great since then. No warning, just smooth.

The only hickup since then was that on one trip it was not registering my voice for hello id or for calls. I reset the infotainment and all was well.

I am very happy that it seems all is well. If an issue was there, in store a warning light would have resurfaced and it had not.

Thank you everyone for all your help, insight, and advice!
 

·
Registered User
Joined
·
798 Posts
So, I wanted to give everyone an update. I ended up canceling my appointment and I figured I would just have them see if there was an error code at the 30 day check up (you can go to any dealer for that, right? )

My car has been great since then. No warning, just smooth.

The only hickup since then was that on one trip it was not registering my voice for hello id or for calls. I reset the infotainment and all was well.

I am very happy that it seems all is well. If an issue was there, in store a warning light would have resurfaced and it had not.

Thank you everyone for all your help, insight, and advice!
I've turned off voice recognition. Too much overhead I use the talk button on the steering wheel spoke. Much faster response and less impact on infotainment system.
 

·
Registered User
Joined
·
787 Posts
So, I wanted to give everyone an update. I ended up canceling my appointment and I figured I would just have them see if there was an error code at the 30 day check up (you can go to any dealer for that, right? )

My car has been great since then. No warning, just smooth.

The only hickup since then was that on one trip it was not registering my voice for hello id or for calls. I reset the infotainment and all was well.

I am very happy that it seems all is well. If an issue was there, in store a warning light would have resurfaced and it had not.

Thank you everyone for all your help, insight, and advice!
Microphone for infotainment screen will sometimes not pass registration when ID4 is booted......this will be resolved in next update.
Orange warning is error that was set in the history but it is not active....Orange errors will clear up after couple cycles. ...all errors will be recorded with time... date.... and other information and how many times happened and how important they are.....when VW technician scans modules for malfunctions.
Here is example
8125 Application server 3 system 1 infotainment

System description: IC3-IVI-S-US
Software number: V04007003S
Software version: 0792
ODX name: EV_MUICASIVIPart
ODX version: 002007
Long coding: 23166030000000000000000000000000000000000000000000

Trouble codes:
B1994F4 - Automotive audio bus (A2B) Defective microphone module
Intermittent
Date: 2021-09-17 02:11:57
Mileage: 2837 km
Priority: 2
Malfunction frequency counter: 1
Unlearning counter: 17
amount_of_nodes: 2
Node number: 1
Node name: Telematics Communication Unit
Node status: ok
Node number: 2
Node name: Microphone module in roof
Node status: ok
Voltage terminal 30: 14.1 V
 

·
Registered User
Joined
·
136 Posts
Discussion Starter · #31 ·
Microphone for infotainment screen will sometimes not pass registration when ID4 is booted......this will be resolved in next update.
Orange warning is error that was set in the history but it is not active....Orange errors will clear up after couple cycles. ...all errors will be recorded with time... date.... and other information and how many times happened and how important they are.....when VW technician scans modules for malfunctions.
Here is example
8125 Application server 3 system 1 infotainment

System description: IC3-IVI-S-US
Software number: V04007003S
Software version: 0792
ODX name: EV_MUICASIVIPart
ODX version: 002007
Long coding: 23166030000000000000000000000000000000000000000000

Trouble codes:
B1994F4 - Automotive audio bus (A2B) Defective microphone module
Intermittent
Date: 2021-09-17 02:11:57
Mileage: 2837 km
Priority: 2
Malfunction frequency counter: 1
Unlearning counter: 17
amount_of_nodes: 2
Node number: 1
Node name: Telematics Communication Unit
Node status: ok
Node number: 2
Node name: Microphone module in roof
Node status: ok
Voltage terminal 30: 14.1 V
Thank you so much! It is good to know that they will see it so that if it is serious they will be able to address it.

BTW, the 30 day check should be free no matter what dealership I go to, right?
 
21 - 31 of 31 Posts
Top